Recuperar GRUB

Después de reinstalar Windows (el que lo tenga), observará que al arrancar de nuevo el GRUB ha "desaparecido".
Bueno, el truco para volver a sonreir viendo el menú del GRUB es:

- Arrancar con un CD live. Yo he usado Ubuntu y Mepis.
- Abrir una consola y teclear:

En Ubuntu:
- sudo -s -H

En la Mepis no hay que hacer nada si entras como root.
Seguimos en la consola y tecleamos según la partición que corresponda:

- grub

root (hd0,0)
setup (hd0)
quit

Reiniciar y volver a disfrutar del GRUB

OJO: tenemos que tener en cuenta la partición en la que está nuestro linux. Explico las equivalencias:

Discos duros:
hda -> hd0
hdb -> hd1
hdc -> hd2
y así sucesivamente.

Particiones:
hda1 -> (hd0,0)
hda2 -> (hd0,1)
hda3 -> (hd0,2)
hdb1 -> (hd1,0)
hdb2 -> (hd1,1)
hdb3 -> (hd1,2)
hdc1 -> (hd2,0)
hdc2 -> (hd2,1)
y asi sucesivamente.

Enviado por metroplex el 13 Marzo, 2007 - 14:01.

Otra manera:

1) Botear con un live cd.
2) Montar la particion root ( / )
3) Hacer un chroot al directorio montado
4) Ejecutar grub-install.
5) Reiniciar

Enviado por Sergio_Yinyang el 28 Marzo, 2007 - 16:26.

Hoy sin reinstalar Windows ni nada, al arrancar me salio un Error 15 de grub y se quedaba ahí.

Probé con MiniKnoppix 2005:

1. sudo fdisk -l
Con esto vi todas las particiones que tenía en el disco duro, en mi caso, en la que tengo instalada Debian es en hda6, o sea que según los patrones que das, para hacer referencia a dicha partición es (hd0,5)

2. sudo -s -H
(En MiniKnoppix 2005 si que es necesario hacer este paso)

3. grub

4. root (hd0,5)
Pulso enter

5. setup (hd0)
Pulso enter

6. quit
Pulso enter

7. reboot
(Para reiniciar)

¡Mi grub vivo de nuevo!
¡Me salvaste la vida ti@!

No sé por qué me paso eso, lo único que hice en mi Microchoff Window$ XP fuera de lo normal fue desfragmentarlo (con Diskeeper y después en el símbolo del sistema hice defrag -f porque Diskeeper tenía problemas) y después pasarle la comprobación de errores integrada en el SSOO para dicha particíón.

Saludos.

Enviado por miguel1111 el 10 Abril, 2007 - 16:00.

Yo he probado en mi debian amd64 y me fallaba al hacerlo con knoppix.
Me he tenido que bajar la ubuntu live amd64 y me ha funcionado correctamente

Enviado por albertdm el 10 Abril, 2007 - 20:22.

Pués a mi no me funcionó hasta que copié los ficheros del directorio grub del Kubuntu con el que lo realize a la partición donde tengo el directorio /boot/grub en mi PC.
De hecho, primero copié los archivos y despues seguí los paso, entonces funcionó a las maravillas

Enviado por bomper el 17 Abril, 2007 - 20:43.

Respuesta a Pués a mi no me

.
Los CDs de instalación de debian Etch (4.0) incluyen una opción para estos casos, pasando la opción "rescue" y/o "rescuequi" en el boot.

Siempre es aconsejable tener una copia del fichero "/boot/grub/menu.lst"

Ya no es necesario utilizar los CD de otras distribuciones.

Enviado por sensono el 19 Agosto, 2008 - 16:51.

kepa escribió:

Después de reinstalar Windows (el que lo tenga), observará que al arrancar de nuevo el GRUB ha "desaparecido"

Esa fué la razón por la que me pasé a GNU/Linux el mismo día en que lo prové, sin partición con Windows; quizás si hubiera visto este artículo antes no lo hubiese hecho, pero ahora estoy contento de la decisión.

Solo hace una semana de eso y llevo leido media internet (porque la tengo en casa guardada en un disco de 3/4 xDDDD)

Salud y gracias!!!