Kernel panic - not syncing

El otro dia estaba actualizando el sistema via apt, cuando se fue la luz en casa, asi que reinicio en cuanto vuelve la luz y me aparece lo siguiente durante la carga del sistema:

exec: 433: /sbin/init: not found
Kernel panic - not syncing: Attempted to kill init!

y ahi se queda.

He probado a arrancar desde un liveCD (Ubuntu) montar los discos y comprobar la existencia del archivo init, que sigue estando donde debiera.

Que puede haber ocurrido?? Tiene solución sin amputación??

Arranca con una Live CD y escanea los sistemas de ficheros del disco duro, quizás haya inconsistencias (o algo peor). Usa fsck, con cuidado.

Se me olvidó comentar que ya le hice un fsck a los dos sistemas, borró un par de inodes y me dijo que ya estaba todo arreglado.

Por si acaso saltaba la liebre, renombre el archivo init a init2 y copie el del liveCD (al más puro estilo windows) revisando el tema de permisos y usuarios y volvi a intentarlo, aun así nada de nada.

el estilo ventanas no suele dar muy buenos resultados ... :)

si con el fsck no arreglas nada, yo probaría a hacer un chroot desde un knoppix o similar, y darle al apt-get instalando un kernel nuevo y cosillas así a ver si reacciona.

salu2

También he probado a arrancar desde otro kernel (ahora mismo tengo 3 kernels por razones de seguridad) y he probado a arrancar desde ellos sin que cambiase nada de uno a otro.

Sobre el tema del chroot pues es algo que tengo pendiente que aún no he aprendido a usar nunca, lo que he ido leyendo por ahi indica que basta con hacer #chroot /particion_a_enrootar y teoricamente ya funcionaría pero nunca he logrado nada y el man del Ubuntu se me corta por un error.

Antes de escribir esto he probado a hacer #chroot /dev/hda5 y me decia que no existe el archivo /bin/sh, sin ningún tipo de explicación mas que me ayude.

Como vereis ando un poco perdido con este tema, sobrepasa mis pequeños conocimientos sobre este sistema, Gracias.

El chroot tiene que estar en /usr/sbin, entra en ese directorio y ejecutalo desde ahí a ver. La verdad que no he usado la live del ubuntu, así que no decirte nada concreto.

Lo único con respecto a lo que has puesto, decirte que tienes que hacer el chroot al directorio donde tienes montada la partición, no al /dev/hdxx

a ver si así ...

salu2

Ya he probado lo que me has dicho chacal y no hay manera

root@ubuntu:/usr/sbin # chroot /mnt/hda5/
chroot: /bin/sh: No such file or directory
root@ubuntu:/usr/sbin # chroot /mnt/hda7/
chroot: /bin/sh: No such file or directory
root@ubuntu:/usr/sbin # chroot /mnt/hda5/ /bin/bash
chroot: /bin/bash: No such file or directory
root@ubuntu:/usr/sbin # chroot /mnt/hda7/ /bin/bash
chroot: /bin/bash: No such file or directory

Estoy empezando a hartarme de esto..... me siento impotente (no sexualemente hablando), pero ya he conseguido leer el man y no me ha dado ninguna pista de que ocurre.

Buscando por el google a otro le pasaba lo mismo con chroot y la unica respuesta que obtuvo fue que revisase que tenia todas las dependencias de librerias de chroot.

Una soluci'on pido. Alguna idea mas?

ah vale, el "error" que te da es que no tiene el chroot, de ahí el "No such file or directory", aunque me parece muy raro... antes de decía que entrases en /usr/sbin para que comprobases si lo tenías, no para ejecutarlo desde ahí, pero para ejecutarlo desde ahí tendrías que indicárselo con ./

así que primero mira a ver si lo tienes en el ubuntu-live y si lo tienes ya sabes, lo ejecutas con ./chroot /mnt/hda5

en caso de que ubuntu no lo tenga knoppix si que lo tiene, prueba con knoppix si tienes uno a mano, y si no, una vez que tengas montada la partición prueba a ejecutar el que tienes en tu sistema. En definitiva sería entrar en /mnt/hda5/usr/sbin, y ejecutar ./chroot /mnt/hda5

a ver que tal ahora ...

salu2

Si el archivo chroot esta en /usr/sbin

root@ubuntu:/usr/sbin # ls -l chroot
-rwxr-xr-x 1 root root 11064 Aug 12 2004 chroot

y aunque tiene permisos de ejecuci'on:

root@ubuntu:/usr/sbin # ./chroot /mnt/hda5/ /bin/bash
./chroot: /bin/bash: No such file or directory
root@ubuntu:/usr/sbin # ./chroot /mnt/hda7/ /bin/bash
./chroot: /bin/bash: No such file or directory
root@ubuntu:/usr/sbin # ./chroot /mnt/hda5/
./chroot: /bin/bash: No such file or directory
root@ubuntu:/usr/sbin # ./chroot /mnt/hda7/
./chroot: /bin/bash: No such file or directory

Asi que aun nada de nada.

Me da cosa seguir con este tema porque te estoy haciendo perder el tiempo, pero no me gustaria tirar mi sistema a la basura y empezar desde el principio, ademas de que asi aprendo a utilizar una nueva herramienta.

joe no tiene sentido ... creo que no se me pasa nada, pero vamos con el día que llevo me espero cualquier cosa :S

a ver si me ilumina la bomibilla dentro de un rato o algún otro nos ilumina, pero es que ya estaba mosqueao y acabo de probarlo en otro pc y si va... no lo entiendo!!

salu2

Ya se que no tiene sentido, pero no hago mas que darle vueltas y vueltas al tema, ma;ana probare con una knoppix antigua que creo que tengo por ahi perdida.

Si a alguien mas se le ocurre alguna otra solucion, estoy abierto a cualquier cosa (hablando figuradamente ehh)