no puedo usar correctamente los acentos en mi teclado

Saludos a todos tengo el siguiente problema con mi teclado, en el teclado tengo funcionando todos los caracteres a excepcion del simbolo del euro ya que no uso el ISO-8859-15 con el soporte para el pero tengo respuesta de la \,@,|,#, etc, pero al querer colocarle los acentos a las vocales el teclado automaticamente escribe el acento al pulsar la tecla y no espera a que pulse la tecla de la vocal, tengo en mi /etc/X11/XF86Config-4 lo siguiente

keyboard "104"
layout "es"
"nodeadkeys"

no recuerdo bien los nombres de las opciones lo estoy haciendo acordandome, lo que se es que si quito "nodeadkeys" no puedo escribir los caracteres especiales, que debo hacer? uso woody r0, gracias por la ayuda.

Hola!
Mira yo lo tengo configurado asi:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Yo en los locales tengo elegidos:
es_ES@euro ISO-8859-15
es_ES ISO-8859-1
es_ES.UTF-8@euro UTF-8
es_ES.UTF-8 UTF-8

Si aun asi no te funciona, prueba a ejecutar el comando kbdconfig (como root) y desde allí lo configuras.
Saludos!

PD: visita este enlace
http://www.tldp.org/HOWTO/Config-HOWTO/x43.html#AEN64