No puedo conectar movil por bluetooth

Hola, llevo ya unas horitas intentando conectar mi movil al PC por medio de un dispositivo bluetooth enchufado al puerto USB y ya no se que mas probar, a ver si podeis aportarme alguna idea.

Uso Debian Etch con KDE 3.5.5 y kernel 2.6.17-2-k7 para un AMD athlon XP. El movil es un Sharp, que no me dio ningun problema de conexion en Kubuntu Dapper.

He instalado todos estos paquetes via apt:
bluetooth, bluez-firmware, bluez-hcidump, bluez-pcmcia-support, bluez-utils, kdebluetooth (+ alguna posible dependencia).

Cuando reinicio me aparece la tipica ventanita pop-up que me dice "kdebluetooth-bluetooth device found" en la parte superior izquierda, por lo que deduzco que no hay problemas con el dispositivo y que los modulos del kernel y el demonio hcid se cargan correctamente (lo compruebo con ksysguard).

Seguidamente en la esquina inferior derecha de la pantalla me aparece otro aviso diciendo que proporcione a bluez's pin helper la ruta hacia /usr/lib/kdebluetooth/kbluepin, por lo que modifico mi /etc/bluetooth/hdci.conf dejandolo asi:

#
# HCI daemon configuration file.
#

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security user;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# PIN helper
pin_helper /usr/lib/kdebluetooth/kbluepin;

# D-Bus PIN helper
#dbus_pin_helper;
}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
name "%h-%d";

# Local device class
class 0x3e0100;

# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
iscan enable; pscan enable;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
lp rswitch,hold,sniff,park;

# Authentication and Encryption (Security Mode 3)
#auth enable;
#encrypt enable;
}

====================

Bueno, pues reinicio y aun asi me resulta imposible hacer que movil y PC se entiendan. En principio el PC si encuentra al movil pero no me permite emparejarlo (despues de meter el pin por defecto:1234) y me aparece una ventanita diciendo: "pairing not allowed". En cambio si busco dispositivos desde el movil, este no ve el PC.

Pruebo a cambiar los distintos parametros referentes a seguridad, conexion y "emparejamiento" y nada.

Arranco con Kubuntu Dapper (liveCD) donde todo funcionaba sin problemas, copio su hcid.conf, lo plagio en mi Debian y ni por esas......

La verdad que estoy un poco desesperao.......Algo de luz sobre el asunto???????? Gracias!

PD: Perdon por la chapa ;)

Hola.
Yo tuve también muchos problemas con 2 moviles, un Sharp y un Motorola. Al final recurrí a copiar la configuración de un amigo Susero y funcionó, eso sí, a costa de reducir la seguridad.

Ahora no tengo mi ordenador por delante, pero creo que podría postear la configuración para que comparases y poder ver las diferencias con la tuya.

Saludos

Pues si tienes un momentillo ponmelo aqui a ver si hace que me inspire un poco. Gracias!

Me tienen que reiniciar el ordenador para entrar en mi Debian (tengo un parasito en mi habitación catalogado como "hermana", adicta al Photoshop, que dice que me puedo comer el Gimp con patatas y que emular no mola, que ella quiere messenger e Ircap o como se llame)

Tengo un servidor ssh funcionando en Windows, pero la partición debian (que se monta automaticamente con el ext2fs al iniciar windows) no aparece integrada en el sistema de ficheros del cygwin, por lo que por sftp no puedo pillarte el archivo.

También tenía un servidor de VNC funcionando en Windows, hasta que mis hermanas (los males siempre vienen de 2 en 2) se las han arreglado (ni ellas saben como) para que deje de funcionar. Creo que el servidor me manda la imagen negra de una sesión suspendida de windows que ni ellas mismas saben que está abierta.

Que quiero decirte con esto: que puede que tarde un dia o 2 en poder postearte el archivo (hasta que a la pequeña le de la gana atender los 200 correos que le voy a mandar).
Y también quiero aprovechar para quejarme públicamente de esos dos bichos que tienen mis mismos apellidos, agghh!!!
Cuando vuelva a casa creo que no va a quedar nada de mi pobre ordenador evil

PD: estoy bastante frustrado en estos momentos cry

Puede que tarde un poco menos..

$ shutdown -r

mrgreen mrgreen mrgreen
devil devil devil

PD: para malo, yo...

Sin prisa maxmalcav. Respecto a todo lo demas no sabes como te entiendo jajajjaj aunque yo solo tengo una hermana, lo de tener 2 tiene que ser criminal.

Te posteo lo que yo tengo en casita.
Con esto el Motorola funciona, y el Sharp creo recordar que sí, pero como es de mi hermana y ella se pasa los archivos en Windows de uno en uno (toma soft privativo warro!). Siempre puedes probar.

No se si es la mejor y más segura de las configuraciones, pero por lo menos a mi me va:

#
# HCI daemon configuration file.
#

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security auto;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# PIN helper
# if you want a interactiv query of your pin use /usr/bin/bluepin
# /bin/bluepincat is using the pin in the /etc/bluetooth/pin file
# pin_helper /usr/bin/bluepin;
pin_helper /usr/bin/bluepin;

# D-Bus PIN helper
#dbus_pin_helper;
}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
name "erebor-linux";

# Local device class
# e.g.
# 0xsss100 = Computer
# 0xsss104 = Computer Desktop
# 0xsss108 = Computer Server
# 0xsss10c = Computer Laptop
# The 'sss' above defines the service-class (not quite, only the
# first 11 bits, the next 11 define the device-class, than 2 format bits.)
# See https://www.bluetooth.org/foundry/assignnumb/document/baseband
# for more information.
# 0x100bbb stands for "Object Transfer (v-Inbox, v-Folder, ...)"
# 0x020bbb stands for "Networking (LAN, Ad hoc, ...)"
class 0x100100;

# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
# valid parameters: enable | disable
iscan enable;
pscan enable;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
lp rswitch,hold,sniff,park;

# Authentication and Encryption (Security Mode 3)
#auth disable;
encrypt disable;
}

Hechando un vistazo a las diferencias entre la tuya y la mia, creo que los problemas pueden probenir de unsar kbluepin. Creo que eso fue lo que al cambiar hizo que empezase a funcionarme, anteriormente me hacía muchos extraños intentando emparejar los dispositivos (y nunca lo lograba)

Saludos

Nada, que no hay manera. Veo que en tu fichero de configuracion le das la ruta /usr/bin/bluepin y en mi debian ese fichero no existe. Pero aunque cambie esa linea y le de la ruta utilizada anteriromente no lo consigo.

Tambien he probado a pasar el parametro del pin a pelo en hcid.conf (lo lei googleando por ahi), incluyendo una linea asi:

passkey "1234";

No se que mas probar. Voy a tener pesadillas con el sonidoto de "POOOOOHHH" cada vez que rechaza la conexion.

El caso es que yo si lo tengo, y lo malo es que no recuerdo en que paquete iba incluido... neutral
Tengo que mirar en mi chiquitín a ver cual fue el conjunto exacto de paquetes que instalé para poner a furular el bluetooth.

Saludos

el paquete es bluez-pin??

jasoriano escribió:

el paquete es bluez-pin??

Te hablo de memoria, pero es más que probable. También me parece recordar que últimamente estaba en la lista de paquetes "obsoletos" en Etch, no se si habrá que recurrir a Sid para conseguirlo.

Repito, hablo de memorieta.

Saludos y gracias por el soplo smile