Squid y Puerto 443 (https).. El problema eterno

Buenas... luego de buscar y buscar y buscar por la red... google, foros, y etceteras parecidas sin poder dar a una solución, pregunto por este medio...
Mi problema (y el de muchos en la red) es squid y los puertos seguros.
Ya leí que squid no cachea contenido cifrado es por eso que no lo deja pasar (para que tendra una regla que si ??? la verdad que todavia no entiendo).
Paso primero a describir la topologia de la red

Maquinas -------- Proxy Squid ------------ Gateway ------ Proxy Padre ---- Internet
10.15.0.0/24 -- 10.15.1.14:3128---- 10.15.1.1 --- 10.10.1.1:80 ----- www

La topologia es simple, tengo que salir a travez del gateway hacia el proxy padre para tomar internet (este es un proxy al cual accedo por el puerto 80, tanto conexiones seguras, como ftp, o como todo aparentemente)

Ahora, les paso mi squid.conf

http_port 3128
cache_peer 10.10.1.1 parent 80 0 no-query default
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern .               0       20%     4320
acl all src 0.0.0.0/0.0.0.0
acl interna src 10.15.0.0/255.255.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT
http_access allow interna
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localhost
http_access deny all
http_reply_access allow all

Segun mi squid.conf , y dejo pasar las conexiones https, o ssl, pero ... nunca pasan.. cuando yo intento conectar por ej a Gmail, me dice :

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: www.google.com:443 

The following error was encountered: 

Connection to 209.85.165.103 Failed 
The system returned: 

    (110) Connection timed outThe remote host or network may be down. Please try the request again. 

Your cache administrator is webmaster. 



--------------------------------------------------------------------------------

Generated Thu, 17 May 2007 13:10:43 GMT by localhost (squid/3.0.PRE5) 

Les comento que tengo solo una placa de red instalada en esa maquina (segun lei no hace falta tener 2 placas).
Y en todos lados dice que hay que hacer que pase directamente al proxy... pero... no se como hacerlo.. digamos, lei que con iptables, use infinidad de comandos... y todavia estoy en la misma... alguien me puede tirar exactamente que es lo que tengo que hacer ???
Aca paso la configuracion de la placa de red tambien por las dudas

auto lo
iface lo inet loopback
iface eth0 inet static
address 10.15.1.14
netmask 255.255.0.0
gateway 10.15.1.1
up route add default gw 10.15.1.1
auto eth0

Gracias !!

Como dices el gran problema HTTPS pero también FTP y GOPHER, lo que debes de hacer es realizar maskering en el firewall para que haga NAT, con eso haces un filtro para los servicios antes mencionados.

Ojo en este tipo de configuración necesitaras tener 2 tarjetas de red.

[EDIT]

http://www.linuxparatodos.net/portal/staticpages/index.php?page=19-0-com...
http://wiki.squid-cache.org/Squid-3.0.PRE4-ReleaseNotes?highlight=%28htt...

acá te encontré algo quizás te pueda ayudar.

umm tengo un problema con squid y no se que es miren en el explorador pongo la configuracion del proxy: xxx.xxx.xxx.x port:8080 y cuando intento entrar a alguna pagina me sale el siguiente anuncio:

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: http://www.google.com.co/

The following error was encountered:

* Access Denied.

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

Your cache administrator is webmaster.
Generated Tue, 12 Jun 2007 14:47:59 GMT by servidor3 (squid/2.6.STABLE)

ahmm y aqui mi configuracion de squid, pues no se que es lo que tengo mal.. (me gustaria una opinion de mi configuracion)

# WELCOME TO SQUID 2.6.STABLE5

# TAG: http_port
http_port 3128
http_port 8080

# TAG: hierarchy_stoplist

#We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# TAG: cache

acl QUERY urlpath_regex cgi-bin ?
cache deny QUERY

# TAG: broken_vary_encoding

acl apache rep_header Server ^Apache
broken_vary_encoding allow apache

# TAG: cache_mem (bytes)

#Default:
cache_mem 32 MB

# TAG: maximum_object_size (bytes)
#Default:
maximum_object_size 4096 KB

# TAG: cache_dir
#Default:
cache_dir ufs /var/spool/squid 1000 16 256

# TAG: access_log
access_log /var/log/squid/access.log squid

# TAG: dns_nameservers
#Default:
dns_nameservers 200.75.51.132 200.75.51.133

# TAG: hosts_file
#Default:
# hosts_file /etc/hosts
#
hosts_file /etc/hosts

# TAG: refresh_pattern
#Suggested default:
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern . 0 20% 4320

# TAG: acl
#Recommended minimum configuration:
acl all src 0.0.0.0/0.0.0.0
acl negados url_regex "/etc/squid/negados"
acl MP3 urlpath_regex .[mM][pP][3]
acl AVI urlpath_regex .[aA][vV][iI]
acl MPEG urlpath_regex .[mM][pP][eE][gG]
acl msnmes req_mime_type -i^application/x-msn-messenger$
acl manager proto cache_object
acl localsrc src 127.0.0.1 192.168.0.0/255.255.255.0
acl localhost src 127.0.0.1/255.255.255.255 192.168.0.0/255.255.255.0
acl localdst dst 127.0.0.1 192.168.0.0/255.255.255.0
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 # https
acl SSL_ports port 563 # snews
acl SSL_ports port 873 # rsync
acl pto25 port 25
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 631 # cups
acl Safe_ports port 873 # rsync
acl Safe_ports port 901 # SWAT
acl purge method PURGE
acl CONNECT method CONNECT
acl webdav method PROPFIND TRACE PURGE PROPPATCH MKCOL COPY MOVE LOCK UNLOCK

# TAG: http_access
#Default:
http_access deny all
#Recommended minimum configuration:
http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all
http_access allow msnmes
http_access deny MP3
http_access deny AVI
http_access deny MPEG
http_access deny negados
http_access allow localsrc

# TAG: http_reply_access
#Default:
# http_reply_access allow all
#Recommended minimum configuration:
http_reply_access allow all

# TAG: icp_access
icp_access allow all

# TAG: miss_access
miss_access allow all

# TAG: cache_effective_group
cache_effective_group proxy

# TAG: visible_hostname
visible_hostname servidor3

# TAG: err_html_text
#Default:
err_html_text Di, no se pudo, hubo un error

# TAG: store_avg_object_size (kbytes)
store_avg_object_size 13 KB

# TAG: always_direct
#Default:
always_direct allow webdav
always_direct allow all

# TAG: header_access
#Default:
header_access X-Forwarded-For deny all
header_access Via deny all

# TAG: offline_mode
#Default:
offline_mode on

# TAG: coredump_dir
#Default:
coredump_dir /var/spool/squid

<b> cry

Creo que el problema es porque no estas dándole permiso a ningún cliente de salir a Internet. Eso lo haces definiendo listas de control de acceso (ACL) y le das permisos con "http_access allow nombre_acl".
Checate los manuales oficiales y actualizados de alcancelibre.org. El portal de linuxparatodos.net fue prácticamente arrebatado al autor de los manuales (Joel Barrios) por un amigo suyo, por lo que los manuales originales y actualizados están en alcancelibre.org.
Saludos.

Ese problema lo tuve y lo solucioné de esta forma:

acl https port 443
http_access allow https

Suerte!!!