Debian Etch y Atheros L2 Fast Ethernet 10/100 Base-T Controller

Buenas, antes de nada me presento, espero ser acogido.

Y ahora mi pequeño problema.

He instalado "Debian Etch 40r6". Me he decidido por esta version por que es la única que consigue arrancar en mi pc.

Bien, yo queria realizar una instalación con el netinstall, para asi poder elegir paquetes y demás pero no he podido ya que no me reconocia la tarjeta de red. (Atheros L2 Fast Ethernet 10/100 Base-T Controller).

Asi que he descargado la version CD de 644 mb y en la instalación le he dicho que omitiera la tarjeta de red, todo perfecto. Pero ahora es cuando viene realmente el problema, no consigo que me detecte la tarjeta y claro, necesito los repositorios. Os juro que he buscado en la web soluciones para mi problema pero será que no sé buscar por que no las he encontrado.

Espero que alguien me eche un cable.

Gracias. Saludos.

¿No te la detecta?
¿No la sabes configurar?
¿Como sabes que no la detecta?
¿Cuál es la salida de un ifconfig -a?

Saludos!

NataSHell escribió:

¿No te la detecta?
¿No la sabes configurar?
¿Como sabes que no la detecta?
¿Cuál es la salida de un ifconfig -a?

Saludos!

Gracias por contestar.

No la detecta por que cuando estoy instalando el sistema operativo me sale un menu donde me invita a elegir un driver de las que muestra por defecto (Ahí es donde le dije que la ignorara), pero en esa lista no está la mia. Se que no la detecta por que el network manager dice que no hay ningun dispositivo de red detectado. Tampoco la sé configurar, lo que he encontrado no ha sido para esta tarjeta.
El comando lo pongo ahora.

Saludos

-EDITO-
Aqui está el resultado del comando:

sandermol@pcdeb:~$ ifconfig -a
bash: ifconfig: command not found

Hola, antes que nada disculpa mi falta de cortesía y bienvenido, existe un lugar especial de presentaciones para que nos cuentes un poco sobre ti.

Primero, por lo que veo no tienes muchos conocimientos del sistema en general. Te pido de favor te des una vuelta por el wiki para comenzar a despejar tus duda.

Segundo, el comando no te lo encontró porque necesitas ser root para ejecutarlo, o indicarle la ruta completa del mismo.

Tercero, no leí que estabas en etch. así tienes tres opciones:
1) Descargas el paquete que contiene tu driver (llamado atl2 y que se encuentra en los repositorios
2) Descargarte el DVD de etchnhalf o lenny
3) Descargar el source y compilarlo tu mismo

Creo que con lo que te he dado podrás solucionar tu problema, saludos!

Gracias.

Me he bajado el .deb "atl2-modules-2.6-486-etchnhalf_2.6.24-6~etchnhalf.1_i386.deb" y lo he intentado instalar como root con esta orden:

dpkg -i atl2-modules-2.6-486-etchnhalf_2.6.24-6~etchnhalf.1_i386.deb

Pero me da problemas de dependencias con etchnhalf que no está instalado.

Creo que este no me vale ya que tengo la version de kernel "2.6.18-6-686"

Gracias otra vez.

Saludos.

Necesitas actualizar primero el kernel: linux-image-2.6.24-etchnhalf.1-686

Gracias por responder.

Siento ser tan pesado pero sigue sin funcionar. He instalado ese kernel y he reiniciado para entrar desde el. Pues bien he intentado instalar otra vez el "driver" atl2 y me sigue tirando el mismo error.

Os lo copio aqui:


dpkg -i atl2-modules-2.6-486-etchnhalf_2.6.24-6~etchnhalf.1_i386.deb

Seleccionando el paquete atl2-modules-2.6-486-etchnhalf previamente no seleccionado.
(Leyendo la base de datos ...
55254 ficheros y directorios instalados actualmente.)
Desempaquetando atl2-modules-2.6-486-etchnhalf (de atl2-modules-2.6-486-etchnhalf_2.6.24-6~etchnhalf.1_i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de atl2-modules-2.6-486-etchnhalf:
atl2-modules-2.6-486-etchnhalf depende de atl2-modules-2.6.24-etchnhalf.1-486; sin embargo:
El paquete `atl2-modules-2.6.24-etchnhalf.1-486' no está instalado.
atl2-modules-2.6-486-etchnhalf depende de linux-latest-modules-2.6.24-etchnhalf.1-486; sin embargo:
El paquete `linux-latest-modules-2.6.24-etchnhalf.1-486' no está instalado.
dpkg: error al procesar atl2-modules-2.6-486-etchnhalf (--install):
problemas de dependencias - se deja sin configurar

Se encontraron errores al procesar:
atl2-modules-2.6-486-etchnhalf

Saludos!

sandermol escribió:

atl2-modules-2.6-486-etchnhalf depende de atl2-modules-2.6.24-etchnhalf.1-486; sin embargo:
El paquete `atl2-modules-2.6.24-etchnhalf.1-486' no está instalado

prueba a instalar primero sus dependencias: atl2-modules-2.6.24-etchnhalf.1-486

Nada, sigue sin funcionar.

Me he estado fijando y el kernel que tengo es "686" mientras que el "driver" que intento instalar es "486" no sé si será eso.

Gracias y saludos.

Sé que está dificil, pero, ¿ a nadie mas se le ocurre algo ?.

Gracias.