Conexion wifi, detecta redes pero no obtiene ip [Solucionado]

Hola!!

He instalado Debian lenny hace unos días y no consigo que la conexion inálambrica funcione. La tarjeta de red es una Intel PRO/Wireless 3945ABG y he instalado el firmware 'firmware-iwlwifi_0.15_all.deb'. Posteriormente instale wicd.

El problema es que, aunque me detecta las redes, no me asigna una IP mediante DHCP, y si pongo una IP estática me conecta pero al 0%%. Esto me sucede teniendo la red abierta, sin encriptación alguna; además me ocurre lo mismo con otras redes que detecta abiertas.

La conexion mediante cable ethernet funciona correctamente, sin ningún tipo de problemas.

El router que tengo es un Conceptronic C54BRS4.

debian:/# uname -a
Linux debian 2.6.26-1-amd64 #1 SMP Fri Mar 13 17:46:45 UTC 2009 x86_64 GNU/Linux

debian:/# lspci | grep PRO
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

debian:/# lsmod | grep iwl
iwl3945 92916 0
firmware_class 12544 1 iwl3945
mac80211 162864 1 iwl3945
cfg80211 30224 2 iwl3945,mac80211
led_class 8968 2 iwl3945,asus_laptop

debian:/# ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr: MI_IP Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fe9c:8987/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:243 (243.0 B) TX bytes:10158 (9.9 KiB)
Interrupt:16 Base address:0x8400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:17 errors:0 dropped:0 overruns:0 frame:0
TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1278 (1.2 KiB) TX bytes:1278 (1.2 KiB)

wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00:00:00:00:00:00-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

debian:/# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"Chainsu"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

debian:/# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:00:00:00:00:00
ESSID:"Chainsu"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=98/100 Signal level=-27 dBm Noise level=-127 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=00000000a74771c6
Cell 02 - Address: 00:00:00:00:00:00
ESSID:"linksys_SES_61848"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=45/100 Signal level=-82 dBm Noise level=-127 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000000120724a9e
Cell 03 - Address: 00:00:00:00:00:00
ESSID:"MyPlace"
Mode:Master
Channel:2
Frequency:2.417 GHz (Channel 2)
Quality=45/100 Signal level=-82 dBm Noise level=-127 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000000e45827181

Mi /etc/network/interfaces está así:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug wlan0
iface wlan0 inet static
address MI_IP
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
gateway 192.168.2.1
# wireless-* options are implemented by the wireless-tools package
wireless-mode managed
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.2.1
wireless-essid Chainsu

iface eth0 inet static
address 192.168.2.102
netmask 255.255.255.0
gateway 192.168.2.1

Gracias de antemano.

Prueba a modificar la interfaz de red inalámbrica en tu /etc/network/interfaces dejándola como sigue:

# The primary network interface
auto wlan0
iface wlan0 inet dhcp

Luego reinicia:

# ifdown wlan0

# ifup wlan0

o

# /etc/init.d/networking restart

Hola!!

Gracias por la ayuda, he probado y no consigo nada. Las salidas son las siguientes:

debian:/# ifdown wlan0
RTNETLINK answers: No such process
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:00:00:00:00:00
Sending on LPF/wlan0/00:00:00:00:00:00
Sending on Socket/fallback

debian:/# ifup wlan0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:00:00:00:00:00
Sending on LPF/wlan0/00:00:00:00:00:00
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Tambien probe esto, pero nada:

If Wicd fails to connect after you install it, make sure that the only entry in your /etc/network/interfaces file is

auto lo
iface lo inet loopback

Prueba a editar tu /etc/network/interfaces

wireless-mode managed
wireless-essid tu-punto-de-acceso
wireless-key off

Luego, ten en cuenta que los clientes como Network Manager y Wicd suelen ser
incompatibles con una conexión configurada en /etc/network/interfaces, es decir,
usas lo uno o lo otro.

.

Hola!!

Gracias por la ayuda, he probado desinstalando el wicd y modificando el /etc/network/interfaces como me indicas y obtengo la misma salida que anteriormente.

¿Si deshabilitas la ethernet ?

Ya he probado con el cable de ethernet desconectado y sigo igual. Gracias.

Hola!!

No creo que sea un problema similar, ya que yo al conectarme con Ip estática obtengo una conexión al 0%% (no tengo). Si me conecto vía ethernet a través del mismo router mediante DHCP va correctamente.

De todas formas instalé dhcpcd y tampoco conseguí nada.

Gracias.

A ver para que me quede claro,Conectándote via wifi,con ip estática ,te asocia al access point,pero tenes una tasa de transferencia ¿cero? esto es ,podes hacer el nexo pero no te integra al resto de la red ,¿entendí bien ?

Esta es la captura de wicd cuando me conecto con ip estática.

Gracias