Pantalla fuera de rango

hola amigos , soy nuevo en debian y en linux, miren mi problema es el siguiente, estaba instalando el compiz fusion en mi pc,
segun esta pagina http://bitnegro.blogspot.com/2007/08/compiz-fusion-en-debian-lenny-con.h...
ya en medio de la instalacion se quedo pegado, y al tratar de entrar nuevamente al debian , podia ingresar hasta donde me pide el user y la pass , pero cuando empieza a cargar el escritorio la pantalla dice " modo analogico, frecuencia fuera de rango 60- 80 mhz"

mi pantalla es una LG 1753t
la tarjeta grafica es la Nvidia Geforce 6150 (instalada)
lei en un lado que hay que modificar el /etc/X11/xorg.conf pero la verdad es que no he encontrado los datos de la pantalla para rellenarlos, si me pudiesen hechar una mano seria genial, gracias adios

hola, ¿has modificado el xorg.conf? tendrías que postear el contenido de tu xorg.conf (si tienes problemas para hacerlo te podría ser de gran ayuda usar un liveCD)

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection

ese es mi archivo, el problema es cuando trato entrar como usuario, al entrar como root no tengo ningun problema

tu xorg.conf parece estar bien. lo que no me queda claro es:

thrash_skywalker escribió:

ese es mi archivo, el problema es cuando trato entrar como usuario, al entrar como root no tengo ningun problema

¿podes entrar a la sesión (gráfica) como root sin problemas? entonces tu problema esta en la configuración de tu $HOME

Agrego:
Puedes comparar el archivo /home/tu_nombre_usuario/.config/monitors.xml de tu usuario con el de root/.config/monitors.xml
saludos...

gracias compa revisare y comentare altiro gracias!!!

Los datos los puedes encontrar en sistema->preferencias->resolucion de pantalla Ahí trae los datos de la velocidad de refresco del monitor.

Si no te funciona lo que dice el compañero prueba a editar en terminal el archivo xorg.conf:

#gedit /etc/X11/xorg.conf

Y deja la sección monitor tal como lo indico:

#
Section "Monitor"
Identifier "Configured Monitor"
        HorizSync       28-64          
        VertRefresh     43-60 
EndSection

En mi caso funciona asi sin ningún problema. No creo que hayas modificado la tasa de velocidad de refresco asi que me parece raro, Puedes probar a modificarla de forma manual hasta que consigas dar en el clavo dentro de unos parámetros un poco normales.

Edito: La tasa de refresco la puedes modificar y en función de la modificación pues en el archivo xorg.conf habrá unos valores u otros. En mi caso el valor es de 60 Hz.

emm mira franky puse esos valores y me sigue saliendo el mensaje, este es
volviendo a modo analogico , señal fuera de rango
81-1Khz / 65Khz

emm no cacho ke valores habria ke ponerles ... sorrye pero recien empiezo aca en linux

y respondiendo a rockyiii

estos son los archivos ke tengo en el /home/miname/.config

emesene1.0 enchant gtk-2.0 menus totem Trolltech.conf

y en root/.config

brasero enchant menus transmission
.. compiz gtk-2.0 totem Trolltech.conf

porfa dime cual hay ke revisar

=adjunto el como entro .
en modo normal no puedo, onda voy en modo single user y para poder entrar al entorno grafico hago el
#startx

y me dice ke ahi entro como adm blah blah etc . esos son los datos ke puedo entregar,
gracias

thrash_skywalker escribió:

emm mira franky puse esos valores y me sigue saliendo el mensaje, este es
volviendo a modo analogico , señal fuera de rango
81-1Khz / 65Khz

emm no cacho ke valores habria ke ponerles ... sorrye pero recien empiezo aca en linux

y respondiendo a rockyiii

estos son los archivos ke tengo en el /home/miname/.config

emesene1.0 enchant gtk-2.0 menus totem Trolltech.conf

y en root/.config

brasero enchant menus transmission
.. compiz gtk-2.0 totem Trolltech.conf

porfa dime cual hay ke revisar

=adjunto el como entro .
en modo normal no puedo, onda voy en modo single user y para poder entrar al entorno grafico hago el
#startx

y me dice ke ahi entro como adm blah blah etc . esos son los datos ke puedo entregar,
gracias

Por favor, procura no poner 'ke' cuando quieres poner 'que'
http://www.esdebian.org/normas-foro
Gracias

Los valores de la configuración de la tarjeta gráfica exceden a los del monitor. A lo mejor el problema está en la resolución de la pantalla. Tienes que mirar en el manual del monitor que tasa de valores de refresco soporta y escribirlos en el archivo xorg.conf

Yo tambien tuve problemas hace tiempo cuando decidí usar la aceleracion 3D. Mi portatil usa una resolución por defecto de "1280x1800" y en la Section "Screen" solo habia en Modes: "1024x768" "800x600" "640x480"

Asi que tuve que añadir "1280x800" y al final funcionaba correctamente. Comprueba la resolución de pantalla tambien y que trabaja con la que tu monitor usa por defecto

Section "Screen"
        Identifier      "Default Screen"
        Monitor    "Configured Monitor"
        DefaultDepth    24
        SubSection "Display"
                Modes       "1280x800" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Yo creo que la frecuencia que tienes que poner en VertRefresh es 60- 80 mhz o similar.

#
Section "Monitor"
Identifier "Configured Monitor"
        HorizSync       28-64         
        VertRefresh     60-80
EndSection

Saludos

Post-data: Mira bien el manual de tu monitor. Ahi tiene que traer los valores de la tasa de refresco que soporta.

Edito: Por cierto no tenías que poner los míos sino los tuyos adaptados a tu caso tongue

Hola thrash_skywalker, efectivamente el archivo monitors.xml no esta en debian lenny, pero sí en squeeze.

Espero que alguna de estas posibles soluciones te sea de ayuda.

* Iniciar normalmente y cuando se pone el monitor fuera de rango hacer la siguiente combinación de teclas:

“CTRL” + “ALT” (izq) + “+” o ”-” (pad numérico)

si funciona ir a sistema/preferencias/pantalla/ y poner una configuración acorde al monitor
otra forma sería ir Aplicaciones/Herramientas del sistema/editor de configuración/-->desktop-->gnome-->screen-->nombre_de_tu_pc-->0 y cambiar los valores a rate 85 y resolución 1024x768

* Editar el archivo “%gconf.xml”
/home/fedemos/.gconf/desktop/gnome/screen/nombre_de_tu_pc/0/%gconf.xml

Y poner un valor en

...
value="85"
...
<stringvalue>1024x768</stringvalue>

en forma gráfica: Aplicaciones/Herramientas del sistema/editor de configuración/-->desktop-->gnome-->screen-->nombre_de_tu_pc-->0 y cambiar los valores a rate 85 y resolución 1024x768

Luego reiniciar la PC

* Configurar la resolución del monitor con el programa “nvidia-settings” o el que traiga el controlador instalado
* Desinstalar el controlador de nvidia privativo
* Desinstalar compiz y quitar la lista de repositorios de compiz, luego volver a instalar compiz pero con los paquetes de debian
* Reconfigurar xorg.conf

sudo dpkg-reconfigure xserver-xorg

Creo que teniendo instalado los controladores privativos de nvidia puede que esta opción no te sirva de ayuda

* Configurar xorg.conf

sudo X -configure

Si te tira algún error podes probar:

sudo invoke-rc.d gdm stop
sudo X -configure
sudo invoke-rc.d gdm start

luego de realizar sudo invoke-rc.d gdm stop se te va a cerrar el entorno gráfico y tu sesión, así que tendrás que volver a poner tu nombre de usuario y pass para luego seguir con el X -configure

El comando sudo X -configure crea en tu directorio /home/tu_nombre_de_usuario/ un archivo xorg.conf.new (se crea con permisos de root) lo abrís y copias su contenido y luego se lo pegas al xorg.conf

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back
sudo mv xorg.conf.new /etc/X11/xorg.conf

Es conveniente que antes de realizar esto, compares el contenido de xorg.conf.new con xorg.conf

sudo gedit  xorg.conf.new

* este es un ejemplo para la parte especifica de la resolución de pantalla que podrías probar
Código:

...
Section "Screen"
....
    DefaultColorDepth 24
   
    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection

Algo muy común es que luego de hacer algunas correcciones manuales al xorg.conf (como la propuesta anteriormente), al reiniciar no se inicie el entorno gráfico, para solucionar ese problema:
Cuando se termine de cargar pones tu nombre de usuario y pass y podes optar por:

a) volver al xorg.conf.back que se creo

sudo cp /etc/X11/xorg.conf.back /etc/X11/xorg.conf

b) editar el xorg.conf e ir quitando los arreglos manuales

sudo nano /etc/X11/xorg.conf

CTRL + o Para guardar
CTRL + x Para cerrar

Sobre la configuración que te propone franky32 , creo que para tu monitor la configuración de los valores del fabricante (30-83) y (56-75) http://www.monitoresonline.com.br/lg1753.htm

Section "Monitor"
Identifier "Configured Monitor"
        HorizSync       30-83        
        VertRefresh      56-75
EndSection

saludos...

mmm hice eso.... y no pude entrar ni como root ... tenia respaldado el xorg.conf asi que pude entrar nuevamente....
= gracias por su ayuda pero dentro de poco tengo que instalar el 2003 server por cuestiones de estudios lo que significa reinstalar debian nuevamente, gracias por su ayuda de todas formas
disculpen la demora en responder pero estoy con examenes eso saludos!!