este sistema operativo no admite la instalacion rápida centro de descargas de flash player [Solucionado]

tengo iceweasel como navegador web en debian-squeeze.

ocurré el mensaje "este sistema operativo no admite la instalación rápida centro de descargas de flash player",
cada vez que corro una aplicación flex,

no creo que se el navegador, porque es similar firefox, ademas si le hace correr directamente un swf lo levanta.

no se alguien le paso esto alguna vez?

me estoy volviendo verde con este tema, estoy intentando correr flex, apache con php -firebird en debian. antes lo tenia en win7 pero ya no me lo banco más a ese sistema.

fernando

disculpen el mensaje exacto es:

"Este sistema operativo no admite la instalación rápida. Para visualizar, visite: Centro de descargas de flash player"

Prueba a instalar flashplugin-nonfree.

Saludos wink

Este hilo...

Mis últimos dos o tres comentarios resuelven el problema de Flash..... Leelos con calma.

Edito:

Mejor el artículo de la wiki

gracias a todos, leí todos los comentarios de ese link y es como yo lo tengo instalado .

pero no creo que sea el problema de flash, creo que el problema está en iceweasel (eso me parece no estoy seguro) porque
si corro directamente el swf lo levanta sin problemas, ej: http://localhost/wupsn_flex/upAdmContactos.swf, luego aparece
la aplicación creada en flex con sus menús y demás elementos de la aplicación.

Pero en flex se crea un html (además del swf y otros ficheros) que llama a ese swf, Ej: http://localhost/wupsn_flex/upAdmContactos.html, este último llamaría a http://localhost/wupsn_flex/upAdmContactos.swf. No hace eso, en su lugar muestra una página con:
"Este sistema operativo no admite la instalación rápida. Para actualizar, visite: Centros de descargas de Flash Player."

¿que querrá decir con que el sistema operativo no admite instalación rápida? vaya a saber!

Desinstalé por las dudas:
mozilla-plugins-gnash
gnash
gnash-common
libswfdec-0.8-0
swfdec-gnome

en el iceweasel en about:plugins

Shockwave Flash
    Nombre de archivo: libflashplayer.so
    Shockwave Flash 9.0 r115
    Tipo MIME                             Descripción        Sufijos    Habilitado
    application/x-shockwave-flash         Shockwave Flash    swf    Si
    application/futuresplash              FutureSplash Player spl       Si

    sigue...

pero todo sigue igual que antes.

proba instalando flashplayer-mozilla que esta en los repositorios de debian-multimedia.org si instalaste flashplugin-nonfree eliminalo, y solo tenés que dejar flashplayer-mozilla. De esa forma seguro que no vas a tener problemas.

saludos...

y por que no sigues el consejo

fernando6867 escribió:

visite el centro de descargas

y bajas el ultimo deb
dice ubuntun pero sirve para debían

resumiendo:
1- bajé el famoso plugins de adobe (el tar.gz), lo descomprimí y pegué en /usr/lib/mozilla/plugins como root. El porqué no creo que sea el plugin el problema:
a- Anda lindo todo los relacionado con flash, youtube.com e incluso si corro un swf en el navegador.
b- Estoy usando amfphp, tiene un aplicación flex para ver los componentes, lo raro es que a esta lo levanta sin ningún problema (es un index.html y su swf, miré el código html y es mismo que el que tengo en mi aplicación).

2. Me instalé un debian squeeze en otra maquina, y me daba el mismo problema,
- me bajé firefox de la página, (la version 3.6.3), es igual a iceweasel solo con otro logo(los dos logos están buenos), y la misma falla.
- se me ocurrió hacer un update, estuvo un rato largo (algo de 700 paquetes), y que pasó después? Funcionó la aplicación de flex bien, tecleaba la página html (de la aplicacion flex) y éste html ahora levanta normalmente el swf (me refiero con html y swf los generado por flex).

quién sabe que pasó? pero la versión de iceweasel pasó de la 3.5.8 a la 3.5.9, puede ser alguna librería que andaba medio mal.

3- Actualicé la maquina (donde arranque con este problema, también con squeeze) donde necesito que anden las aplicaciones flex bien; pero lo raro es que el actualizar de synaptic hace rato que no detectaba nuevas actualizaciones, pero con aptitude update tiene como 1Gb de actualizaciones. (y otro tanto de desinstalación). luego de la instalación todo igual que antes = el mismo problema.

4- Borré la carpeta .mozilla de la carpeta de usuario. y esto "PARECE" que arregló el tema.

conclusión: no se pero algo quedo mal en esa carpeta, que al borrarla se generó de vuelta al ejecutar el iceweasel. una de las causas pudo haber sido el plugins de no-script (aunque nunca me mostró que bloqueaba esa página).
No era el navegador, por que con el firefox bajado del sitio oficial me hacia lo mismo. (aunque firefox = iceweasel), con epiphany también hace algo parecido (directamente no muestra nada) pero creo que se lleva mal con las aplicaciones flash desde el vamos.
No era ninguna librería rara, porque después de actualizarlo seguía igual.

bueno, gracias gente, en uno de los comentarios de ese link que me pasaron decía que alguien había borrado la carpeta .mozilla (o toda la carpeta de usuario) y le funcionó el flash, no lo había probado a eso porque lo demás andaba bien (youtube y demás cosas con flash).

fernando

descubrí el problema:
En la carpeta .mozilla (la original) tenía una carpeta llamada plugins y ahí estaba el libflashplayer.so (LNX 9,0,115,0); cosa que la nueva .mozilla no tenia dicha carpeta, esta ultima está tomando el plugins de /usr/lib/mozilla/plugins (LNX 10,0,45,2), última versión que bajé directamente de adobe.

Bueno ahí estaba la joda de esto, problema de versiones, algo en la carga de los swf debe necesitar de esa versión de flash (aunque corriéndolos directamente andaban). capaz que para epiphany halla algo de eso también, después cuando me quede algo de tiempo voy a buscar sobre eso.

* si instalas flashplayer-mozilla y eliminas gnash mozilla-plugins-gnash flashplugin-nonfree vas a tener flash en todos los navegadores
* si instalas flashplugin-nonfree y no eliminas gnash mozilla-plugins-gnash vas a tener flash en todos los navegadores
* si instalas flashplugin-nonfree y eliminas gnash mozilla-plugins-gnash vas a tener que hacer un enlace del libflashplayer.so proporcionado por el paquete a iceweasel en /home/tu_usuario/.mozilla/firefox/plugins o a /usr/lib/mozilla/plugins pero los otros navegadores no van a tener flash

Estoy más que seguro que tanto flashplayer-mozilla como flashplugin-nonfree usan el libflashplayer.so de adobe, Yo particularmente prefiero flashplayer-mozilla claro que cada uno hace su propia experiencia.

saludos...