Paquete no tiene candidato para su instalacion [Solucionado]

Buen dia, desde hace ya tiempo he querido bajar varios programas desde apt o aptitude, y seguidamente me han estado tirando este error:

andres@debian:~/Desktop/debian/Random/pdfs$ sudo apt-get install gnome-apt
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
El paquete gnome-apt no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
E: El paquete gnome-apt no tiene candidato para su instalación
andres@debian:~/Desktop/debian/Random/pdfs$ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

Esto ha sido demasiado frecuente, se puede hacer algo?, Dejo algunos datos:

andres@debian:~/Desktop/debian/Random/pdfs$ cat /etc/debian_version
5.0.1

Kernel: 2.6.26-2-686
Gestor grafico: Gnome
Muchisimas gracias!

empecemos por ver tus repositorios

$ cat /etc/apt/sources.list

¿Actualizaste la lista ?

Aqui mis repos

andres@debian:/mnt/usb$ cat /etc/apt/sources.list
deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main

# Repositorios Oficiales binarios
deb http://http.us.debian.org/debian lenny main non-free contrib
deb http://security.debian.org/ lenny/updates main contrib non-free

# Repositorios Oficiales fuentes
deb-src http://http.us.debian.org/debian lenny main non-free contrib

# Repositorios Multimedia
#apt-get install debian-multimedia-keyring
deb http://www.debian-multimedia.org lenny main
deb-src http://www.debian-multimedia.org lenny main

Disculpa, hace tiempo hice un apt-get update, pero en realidad no recuerdo :s.

A ver, lo usual antes de instalar/consultar algo ,es :

#aptitude update
#aptitude install <paquete>

http://www.esdebian.org/wiki/tutorial-aptitude

alvaradogunner escribió:

Buen dia, desde hace ya tiempo he querido bajar varios programas desde apt o aptitude, y seguidamente me han estado tirando este error:

andres@debian:~/Desktop/debian/Random/pdfs$ sudo apt-get install gnome-apt
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
El paquete gnome-apt no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
E: El paquete gnome-apt no tiene candidato para su instalación
andres@debian:~/Desktop/debian/Random/pdfs$ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

Esto ha sido demasiado frecuente, se puede hacer algo?, Dejo algunos datos:

andres@debian:~/Desktop/debian/Random/pdfs$ cat /etc/debian_version
5.0.1

Kernel: 2.6.26-2-686
Gestor grafico: Gnome
Muchisimas gracias!

Compañero, te manda ese error porque no esta en los repositorios. De todos modos revisa tus repositorios y copialos aquí.

Edito: llegue tarde... bueno lo mas seguro ese paquete ya no este en la versión de lenny

saludos

Caliban:

andres@debian:~$ sudo aptitude update
E: No se pudo abrir el fichero de bloqueo '/var/lib/apt/lists/lock' - open (2 No existe el fichero o el directorio)
E: No se pudo bloquear el directorio de listas...¿es el administrador?

Frittos:

Mis repos estan arriba

alvaradogunner escribió:

Caliban:

andres@debian:~$ sudo aptitude update
E: No se pudo abrir el fichero de bloqueo '/var/lib/apt/lists/lock' - open (2 No existe el fichero o el directorio)
E: No se pudo bloquear el directorio de listas...¿es el administrador?

Frittos:

Mis repos estan arriba

Estas tratando de usar aptitude como usuario ,por eso no podes .y tampoco lo tenes incluido en la lista de sudoers ,hacelo como root

$ su
Passwd:
# aptitude update

http://packages.debian.org/lenny/gnome-apt

caliban, aqui como me dijiste:

debian:/home/andres# aptitude update
E: No se pudo abrir el fichero de bloqueo '/var/lib/apt/lists/lock' - open (2 No existe el fichero o el directorio)
E: No se pudo bloquear el directorio de listas...¿es el administrador?
debian:/home/andres#

Y si estoy en lista creo:

# User privilege specification
root    ALL=(ALL) ALL
andres ALL=(ALL) ALL

asegurate que no tienes abierto aptitude , o synaptics .

Me solia suceder, y lo solucionaba borrando el fichero "lock" que te manda el mensaje de error.
Luego haces aptitude update, luego un aptitude upgrade, y ya podrias instalar gnome-apt, que si esta en los repositorios: http://packages.debian.org/lenny/gnome-apt y Lenny con sus actualizaciones, creo que ya anda por 5.0.3 ó 5.0.5

Salu!

EDITO: lo que puso tlacuacheoscuro aca arriba es otra opcion del porque el error ese tongue