Unidad de CD/DVD la abro pero se cierra sola e inmediatamente

Saludos amigos de esdebian.org...

En esta oportunidad traigo un nuevo reto para los que usamos Debían, resolver cada reto es garantizar la existencia de la distribución, sabemos que es la mejor, pero no es suficiente tenemos que demostrarlo.... ahora bien... como hice otro tema el cual ya resolví era la configuración del monitor en esta pc de escritorio, la cual es de un amigo y hace 3 días le instale Debían Squeeze... arquitectura I386, procesador amd semprom, tenia un problema con el monitor y lo resolví configurando manualmente el archivo /etc/X11/xorg.conf, pero ahora el problema es que la unidad de CD/DVD le aprieto el botón para abrirla, ella se abre pero una vez abierta inmediatamente se cierra, estuve buscando los archivos de configuración de esa unidad en la direccion /etc/media/cdroom y esta en blanco, me metí en las propiedades del disco y me sale que no esta identificado o reconocido, pero si uno abre la unidad y le metes rápido un dvd cuando lo lee, funciona el problema es que no se queda abierto a esperar a que introduzca un CD o DVD y luego yo lo cierre manualmente como debería de ser.... busque por varios lugares y ningún tema que trate sobre esto si alguien por favor podría decirme alguna pagina, link, o web que me oriente para resolver el problema se lo agradecería, así mismo tengo una interrogante.... para las lapto existe el paquete lapto-detect el cual ayuda a instalar los driver de los hardware que trae la maquina, pero para los pc de escritorio existe algún paquete similar o pudiera ser el mismo ya que el ayudaría a reconocer todo el hardware y seguramente solo la maquina con la instalación del paquete, reiniciar y actualizar seguramente se resuelven todos los problemas......

Saher escribió:

Saludos amigos de esdebian.org...

En esta oportunidad traigo un nuevo reto para los que usamos Debían, resolver cada reto es garantizar la existencia de la distribución, sabemos que es la mejor, pero no es suficiente tenemos que demostrarlo.... ahora bien... como hice otro tema el cual ya resolví era la configuración del monitor en esta pc de escritorio, la cual es de un amigo y hace 3 días le instale Debían Squeeze... arquitectura I386, procesador amd semprom, tenia un problema con el monitor y lo resolví configurando manualmente el archivo /etc/X11/xorg.conf, pero ahora el problema es que la unidad de CD/DVD le aprieto el botón para abrirla, ella se abre pero una vez abierta inmediatamente se cierra, estuve buscando los archivos de configuración de esa unidad en la direccion /etc/media/cdroom y esta en blanco, me metí en las propiedades del disco y me sale que no esta identificado o reconocido, pero si uno abre la unidad y le metes rápido un dvd cuando lo lee, funciona el problema es que no se queda abierto a esperar a que introduzca un CD o DVD y luego yo lo cierre manualmente como debería de ser.... busque por varios lugares y ningún tema que trate sobre esto si alguien por favor podría decirme alguna pagina, link, o web que me oriente para resolver el problema se lo agradecería, así mismo tengo una interrogante.... para las lapto existe el paquete lapto-detect el cual ayuda a instalar los driver de los hardware que trae la maquina, pero para los pc de escritorio existe algún paquete similar o pudiera ser el mismo ya que el ayudaría a reconocer todo el hardware y seguramente solo la maquina con la instalación del paquete, reiniciar y actualizar seguramente se resuelven todos los problemas......

¿No se te ha ocurrido pensar que es a causa del hardware? *****, es que ya se le echa la culpa de todo al software....

$ eject

¿Responde ?

Saludos amigo, no he dicho que el es culpa del software, si lo insinué me disculpan para MI debian es perfecto, me refiero a que el problema debe ser configuración del dispositivo, me gustaría saber donde configurarlo y como, también pudiera ser que es como dices pudiera ser culpa del hardware, pero no lo había pensado ya que confío tanto en debian y su perfección que estoy seguro que esta soportado, cabe destacar la placa madre tiene hardware SIS es la única que no esta soportada en debian hasta ahora, ya que esa compañía china no quiere colaborar y dar el código de fuente para realizar los paquetes compatibles con Linux, así bien es la situación, por eso preguntaba si había un paquete similar al lapto-detect para un pc de escritorio seguramente el ayudaría a resolver automáticamente esos detalles si en una lapto funciona en una pc debe funcionar mas rápido la autodetección, la autoactivación y la autoconfiguración, si una lapto es mas compleja en una pc de escritorio debe ser mas fácil, por eso debian es debian y seguirá siendo debian.....

Yo tenía el mismo problema, pero a la inversa, la unidad no se cerraba, le daba al botón, y esta se cerraba pero al cabo de unos segundo volvía eyectar la bandeja. Era un problema de hardware.

Para descartar un problema de hardware en la unidad, que eso nunca hay que descartarlo, debes probar la unidad sólo con el cable de alimentación sin que esté conectado el cable de datos de la unidad al PC, si se comporta igual que cuando está conectada al cable de datos sería signo de que se trata de un problema hardware.

Encuanto a que no encuentras nada sobre este problema:
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/546373
http://social.answers.microsoft.com/Forums/en-US/vistaperformance/thread...
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/295732
https://bugzilla.redhat.com/show_bug.cgi?id=507908
https://bugs.launchpad.net/fedora/+source/udev/+bug/283316
https://bugzilla.redhat.com/show_bug.cgi?id=453095
http://www.fixya.com/support/t1350039-technics_sc_ch515_cd_tray_not_stay...

Como ves hay un poco de todo en la red.

si funciona amigo, pero al segundo se vuelve a cerrar....

ok amigo gracias, si no he descartado problemas del hardware, perooooo, cuando inicio el sistema abro le unidad de CD/DVD y funciona perfecto, me refiero al inicio cuando se ve el BIOS, pero en lo que pasa la imagen del grub, que comienza a cargarse el sistema, se cierra y a partir de ahí cada vez que lo abro se cierra solo.... voy a revisar los link que me diste a ver que consigo......

Que tal si entras al Bios, y desde ahi haces las pruebas. La abres y si se cierra sola pues no hay duda de que es daño de Hardware.

ya lo hice amigo, y funciona perfecto, pero en lo que comienza a cargar el sistema debian despues que pasa el grub, se cierra y comienza la falla sera que es un bug, la version es squeeze y los repositorios estan dirigidos a squeeze es esa maquina yo los tengo dirigidos a testing claro la mia es una lapto, el entorno grafico es gnome, busco y busco, y nada que encuentro algo, seguire buscando......

Saher escribió:

ya lo hice amigo, y funciona perfecto, pero en lo que comienza a cargar el sistema debian despues que pasa el grub, se cierra y comienza la falla sera que es un bug, la version es squeeze y los repositorios estan dirigidos a squeeze es esa maquina yo los tengo dirigidos a testing claro la mia es una lapto, el entorno grafico es gnome, busco y busco, y nada que encuentro algo, seguire buscando......

Pues tu problema es idéntico o muy parecido a este: https://bugs.launchpad.net/fedora/+source/udev/+bug/283316

Es uno de los enlaces que te pasé antes.

Sólo comento que mi problema era similar: la charola (Dell Optiplex GX1) se abría y se cerraba de manera espontánea durante horas. Tiene instalado Debian Lenny, y realizo actualizaciones aproximadamente cada mes. Creía que era problema del software, después me enteré en varios foros que el hardware de Dell tiene esos problemas conocidos. Cómo y por qué dejó de existir el problema no lo sé, simplemente un día la charola del CD ya no se volvió a comportar de esa manera ... y no, no creo que alguien se haya metido en mi máquina pues tengo cierta seguridad configurada y revisé varios logs.

Saludos,
Sidd.