Como puedo instalar mysql workbench.. [Solucionado]

Hola, e intentado instalar mysql-workbench y no se como hacerlo.

Descargue el paquete desde la pagina oficial: mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb (Lei en un blog que se puede usar en debian) y al tratar de instalar( dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb) me salen estos errores:

Citar

Copia:/home/jorge# dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb
Seleccionando el paquete mysql-workbench-gpl previamente no seleccionado.
(Leyendo la base de datos ...
67509 ficheros y directorios instalados actualmente.)
Desempaquetando mysql-workbench-gpl (de mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de mysql-workbench-gpl:
mysql-workbench-gpl depende de libatk1.0-0 (>= 1.29.3); sin embargo:
La versión de `libatk1.0-0' en el sistema es 1.22.0-1.
mysql-workbench-gpl depende de libcairo2 (>= 1.7.2); sin embargo:
La versión de `libcairo2' en el sistema es 1.6.4-7.
mysql-workbench-gpl depende de libcairomm-1.0-1 (>= 1.6.4); sin embargo:
La versión de `libcairomm-1.0-1' en el sistema es 1.6.0-1.
mysql-workbench-gpl depende de libfontconfig1 (>= 2.8.0); sin embargo:
La versión de `libfontconfig1' en el sistema es 2.6.0-3.
mysql-workbench-gpl depende de libgdk-pixbuf2.0-0 (>= 2.21.6); sin embargo:
El paquete `libgdk-pixbuf2.0-0' no está instalado.
mysql-workbench-gpl depende de libglibmm-2.4-1c2a (>= 2.25.4); sin embargo:
La versión de `libglibmm-2.4-1c2a' en el sistema es 2.16.4-1.
mysql-workbench-gpl depende de libgtkmm-2.4-1c2a (>= 1:2.20.0); sin embargo:
La versión de `libgtkmm-2.4-1c2a' en el sistema es 1:2.12.7-1.
mysql-workbench-gpl depende de liblua5.1-0; sin embargo:
El paquete `liblua5.1-0' no está instalado.
mysql-workbench-gpl depende de libmysqlclient16 (>= 5.1.21-1); sin embargo:
El paquete `libmysqlclient16' no está instalado.
mysql-workbench-gpl depende de libpangomm-1.4-1 (>= 2.26.0); sin embargo:
El paquete `libpangomm-1.4-1' no está instalado.
mysql-workbench-gpl depende de libpcre3 (>= 7.7); sin embargo:
La versión de `libpcre3' en el sistema es 7.6-2.1.
mysql-workbench-gpl depende de libpopt0 (>= 1.16); sin embargo:
La versión de `libpopt0' en el sistema es 1.14-4.
mysql-workbench-gpl depende de libpython2.6 (>= 2.6); sin embargo:
El paquete `libpython2.6' no está instalado.
mysql-workbench-gpl depende de libsqlite3-0 (>= 3.7.2); sin embargo:
La versión de `libsqlite3-0' en el sistema es 3.5.9-6.
mysql-workbench-gpl depende de libstdc++6 (>= 4.4.0); sin embargo:
La versión de `libstdc++6' en el sistema es 4.3.2-1.1.
mysql-workbench-gpl depende de libuuid1 (>= 2.16); sin embargo:
La versión de `libuuid1' en el sistema es 1.41.3-1.
mysql-workbench-gpl depende de libxml2 (>= 2.7.4); sin embargo:
La versión de `libxml2' en el sistema es 2.6.32.dfsg-5+lenny3.
mysql-workbench-gpl depende de libzip1 (>= 0.8); sin embargo:
El paquete `libzip1' no está instalado.
mysql-workbench-gpl depende de python-paramiko; sin embargo:
El paquete `python-paramiko' no está instalado.
mysql-workbench-gpl depende de python-pexpect; sin embargo:
El paquete `python-pexpect' no está instalado.
mysql-workbench-gpl depende de mysql-client; sin embargo:
El paquete `mysql-client' no está instalado.
dpkg: error al procesar mysql-workbench-gpl (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
mysql-workbench-gpl

ahora tambien tengo un paquete que descargue mysql-workbench-gpl-5.2.31a-src.tar.gz que lo descomprimi pero que no se como ejecutarlo.

Que puedo hacer ahora? se pueden actualizar e instalar las dependencias??

Fijate si te sirve esto

gracias por comentar, pues segui las indicaciones del link que me paso y no logro instalar, siguen habiendo errores en las dependencias.

Citar

Copia:/home/jorge# dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb
Seleccionando el paquete mysql-workbench-gpl previamente no seleccionado.
(Leyendo la base de datos ...
65585 ficheros y directorios instalados actualmente.)
Desempaquetando mysql-workbench-gpl (de mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de mysql-workbench-gpl:
mysql-workbench-gpl depende de libgdk-pixbuf2.0-0 (>= 2.21.6); sin embargo:
El paquete `libgdk-pixbuf2.0-0' no está instalado.
mysql-workbench-gpl depende de libglibmm-2.4-1c2a (>= 2.25.4); sin embargo:
La versión de `libglibmm-2.4-1c2a' en el sistema es 2.24.2-1.
mysql-workbench-gpl depende de libmysqlclient16 (>= 5.1.21-1); sin embargo:
El paquete `libmysqlclient16' no está instalado.
mysql-workbench-gpl depende de libpopt0 (>= 1.16); sin embargo:
La versión de `libpopt0' en el sistema es 1.14-4.
mysql-workbench-gpl depende de libpython2.6 (>= 2.6); sin embargo:
El paquete `libpython2.6' no está instalado.
mysql-workbench-gpl depende de libuuid1 (>= 2.16); sin embargo:
La versión de `libuuid1' en el sistema es 1.41.3-1.
mysql-workbench-gpl depende de python-paramiko; sin embargo:
El paquete `python-paramiko' no está instalado.
mysql-workbench-gpl depende de python-pexpect; sin embargo:
El paquete `python-pexpect' no está instalado.
mysql-workbench-gpl depende de mysql-client; sin embargo:
El paquete `mysql-client' no está instalado.
dpkg: error al procesar mysql-workbench-gpl (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
mysql-workbench-gpl

o no instalar las actualizaciones que sugerio el blog al cual me remitiste me causo problemas con gnome.
Tengo problemas para abrir el gdit desde la consola, las apariencias se borraron casi todas y el nautilus no me funciona.

Dale un vistazo al siguiente tutorial.

Dale click Aquí

Saludos

Mientras pruebo lo que me sugieres, como aria para resolver los nuevos errores que tengo, que principalmente son con gnome?? confuso

hola, pues no hay forma de instalarlo.
Para recuperar parte de los errores que tenia con gnome he tenido que desactualizar algunos paquetes que indique despues de la primera sugerencia. Aunque aun tengo el problema al ejecutar nautilus y gedit.

Ahora una vez vuelta el instalador de mysql workbench me pide que los actualize(Que royo). acaso nadie tiene workbench en debian lenny? no otra forma de instalar? neutral

copia escribió:

Hola, e intentado instalar mysql-workbench y no se como hacerlo.

Descargue el paquete desde la pagina oficial: mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb (Lei en un blog que se puede usar en debian) y al tratar de instalar( dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb) me salen estos errores:

Citar

Copia:/home/jorge# dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb
Seleccionando el paquete mysql-workbench-gpl previamente no seleccionado.
(Leyendo la base de datos ...
67509 ficheros y directorios instalados actualmente.)
Desempaquetando mysql-workbench-gpl (de mysql-workbench-gpl-5.2.31a-2ubu1010-i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de mysql-workbench-gpl:
mysql-workbench-gpl depende de libatk1.0-0 (>= 1.29.3); sin embargo:
La versión de `libatk1.0-0' en el sistema es 1.22.0-1.
mysql-workbench-gpl depende de libcairo2 (>= 1.7.2); sin embargo:
La versión de `libcairo2' en el sistema es 1.6.4-7.
mysql-workbench-gpl depende de libcairomm-1.0-1 (>= 1.6.4); sin embargo:
La versión de `libcairomm-1.0-1' en el sistema es 1.6.0-1.
mysql-workbench-gpl depende de libfontconfig1 (>= 2.8.0); sin embargo:
La versión de `libfontconfig1' en el sistema es 2.6.0-3.
mysql-workbench-gpl depende de libgdk-pixbuf2.0-0 (>= 2.21.6); sin embargo:
El paquete `libgdk-pixbuf2.0-0' no está instalado.
mysql-workbench-gpl depende de libglibmm-2.4-1c2a (>= 2.25.4); sin embargo:
La versión de `libglibmm-2.4-1c2a' en el sistema es 2.16.4-1.
mysql-workbench-gpl depende de libgtkmm-2.4-1c2a (>= 1:2.20.0); sin embargo:
La versión de `libgtkmm-2.4-1c2a' en el sistema es 1:2.12.7-1.
mysql-workbench-gpl depende de liblua5.1-0; sin embargo:
El paquete `liblua5.1-0' no está instalado.
mysql-workbench-gpl depende de libmysqlclient16 (>= 5.1.21-1); sin embargo:
El paquete `libmysqlclient16' no está instalado.
mysql-workbench-gpl depende de libpangomm-1.4-1 (>= 2.26.0); sin embargo:
El paquete `libpangomm-1.4-1' no está instalado.
mysql-workbench-gpl depende de libpcre3 (>= 7.7); sin embargo:
La versión de `libpcre3' en el sistema es 7.6-2.1.
mysql-workbench-gpl depende de libpopt0 (>= 1.16); sin embargo:
La versión de `libpopt0' en el sistema es 1.14-4.
mysql-workbench-gpl depende de libpython2.6 (>= 2.6); sin embargo:
El paquete `libpython2.6' no está instalado.
mysql-workbench-gpl depende de libsqlite3-0 (>= 3.7.2); sin embargo:
La versión de `libsqlite3-0' en el sistema es 3.5.9-6.
mysql-workbench-gpl depende de libstdc++6 (>= 4.4.0); sin embargo:
La versión de `libstdc++6' en el sistema es 4.3.2-1.1.
mysql-workbench-gpl depende de libuuid1 (>= 2.16); sin embargo:
La versión de `libuuid1' en el sistema es 1.41.3-1.
mysql-workbench-gpl depende de libxml2 (>= 2.7.4); sin embargo:
La versión de `libxml2' en el sistema es 2.6.32.dfsg-5+lenny3.
mysql-workbench-gpl depende de libzip1 (>= 0.8); sin embargo:
El paquete `libzip1' no está instalado.
mysql-workbench-gpl depende de python-paramiko; sin embargo:
El paquete `python-paramiko' no está instalado.
mysql-workbench-gpl depende de python-pexpect; sin embargo:
El paquete `python-pexpect' no está instalado.
mysql-workbench-gpl depende de mysql-client; sin embargo:
El paquete `mysql-client' no está instalado.
dpkg: error al procesar mysql-workbench-gpl (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
mysql-workbench-gpl

ahora tambien tengo un paquete que descargue mysql-workbench-gpl-5.2.31a-src.tar.gz que lo descomprimi pero que no se como ejecutarlo.

Que puedo hacer ahora? se pueden actualizar e instalar las dependencias??

Ayer lo instalé justito. Hice una guía en mi blog.

no funciona, para nada.
Siempre me dice que tengo que actualizar ciertas cosas y no se como se hace.

Depende: libgdk-pixbuf2.0-0 (>= 2.21.6) pero no es instalable
Depende: libglibmm-2.4-1c2a (>= 2.25.4) pero 2.24.2-1 está instalado

Yo creo que ya no se puede.

Hola, bueno hoy intente instalar nuevamente mysql-workbench y ya lo he logrado instalar.
Lo que se tiene que hacer es descargar el programa desde la pagina oficial, para ubuntu 10.04 y solo habra un problema de dependencia que tras instalar, workbench funciona correctamente.

Eso es todo gracias a todos.

Tengo Lenny, Instale el Workbench como dijo

dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1004-i386.deb , pero me dio un error

--"Lastima que no lo guarde"

Lei en otro website, que había que instalar otras dependencias primero, así que ejecute lo siguiente

aptitude search libcairomm-1.0-1 libglibmm-2.4-1c2a libgtkmm-2.4-1c2a libpangomm-1.4-1 libzip1 liblua5.1-0

y luego nuevamente

dpkg -i mysql-workbench-gpl-5.2.31a-2ubu1004-i386.deb..

root lenny escribió:

Seleccionando el paquete mysql-workbench-gpl previamente no seleccionado.
(Leyendo la base de datos ...
137390 ficheros y directorios instalados actualmente.)
Desempaquetando mysql-workbench-gpl (de .../mysql-workbench-gpl-5.2.31a-2ubu1004-i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de mysql-workbench-gpl:
mysql-workbench-gpl depende de libcairo2 (>= 1.7.2); sin embargo:
La versión de `libcairo2' en el sistema es 1.6.4-7.
mysql-workbench-gpl depende de libcairomm-1.0-1 (>= 1.6.4); sin embargo:
La versión de `libcairomm-1.0-1' en el sistema es 1.6.0-1.
mysql-workbench-gpl depende de libgtkmm-2.4-1c2a (>= 1:2.20.0); sin embargo:
La versión de `libgtkmm-2.4-1c2a' en el sistema es 1:2.12.7-1.
mysql-workbench-gpl depende de libpangomm-1.4-1 (>= 2.26.0); sin embargo:
El paquete `libpangomm-1.4-1' no está instalado.
dpkg: error al procesar mysql-workbench-gpl (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
mysql-workbench-gpl

y luego de varios errores se instalo ..

Por fin pude ingresar a la aplicación, me conecte a la BD, y estaba contento, pero cuando intente hacer la opción
"create eer model from existing database" hice el proceso de conectame a la BD y todo bien, cuando al final me dice
"select objects to reverse engineer" secciono las tablas y le doy a la opción "place imported objects on a diagram" y se cierra. si no seleciono esta opción, el proceso termina normal mente. Pero lo que necesito es el modelo de la BD actual..

Me pasa lo mismo cuando creo un nuevo modelo e intento agregar una tabla se cierra la aplicación.

Ya tengo más de 2 semanas en esto.. y he buscado por todas partes y no consigo mucho..

Que podrá ser??

Gracias de antemano