como hacer para que xampp me funcione con mysql y postgres?

Que tal!.

Espero me puedan ayudar, intento hacer que mi xampp soporte postgres, para lo que me baje postgres 9 y ya lo tengo instalado.
Luego intente activar el driver de postgre como en el "inombrale-windows" el hecho es que no es así como funciona, según esto me baje el addon y lo instale.

Ahora cuando quiero hacerlo correr me di cuenta que baje el phppgadmin y pues me quize conectar como con el phpmyadmin. puse como datos mi user: rootpw y pass lampp como la ultima indicacion que aparece al instalar el addon y no conecta.

Probe con para el servidor de postgres e intente nuevamente, no funciono.
Ensendi el servidor, y coloque mis datos de acceso del postgre y salgo del login y me aparecen tres errores propios creo yo de php.

Citar

Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/phppgadmin/classes/Misc.php on line 287

Deprecated: Function split() is deprecated in /opt/lampp/phppgadmin/libraries/adodb/drivers/adodb-postgres64.inc.php on line 393

Deprecated: Function eregi() is deprecated in /opt/lampp/phppgadmin/classes/database/Connection.php on line 53

Pense que me habia conectado e intente probar pero con mi aplicacion y no me sale.

vaya no se puede editar el tema, solo queria anotar que trabajo con xampp y codeigniter como framework.

Al framework, le agrege doctrine como plugin y funciona perfectamente con mysql pero no con postgres.

Acabo de hacer una prueba con otra aplicacion que no tiene doctrine y si me reconoce a postgres por lo que creo que me conecto bien.

Ahora solo quedaria dos preguntas. los errores de deprecated se corrigen?? o existe algun addon mas nuevo para xampp??

Utilizar esta pc con Linux como un servidor web, ya sea para hacer pruebas de sitios web, o bien como un servidor para una pequeña intranet en casa o en la oficina.
Un método “sencillo”, si, entre comillas, es instalar Apache, MySQL, sendmail, PHP5, etc. en tu sistema de archivos. Sin embargo, si te equivocas en algo, puedes colgar el sistema.

XAMPP, antes LAMPP (iniciales de Linux, Apache, MySQL, PHP y Perl) es un magnífico entorno que viene con todo listo. No requiere instalación, solo se copian los archivos y se inicia XAMPP.

Es más, si algo salió mal, si moviste algo que no debías, tiras a la basura el folder de XAMPP, lo vuelves a copiar y listo!! De nuevo quedará funcionando.

El pero…

Todo esto es magnífico, solo que XAMPP se instala en el directorio /opt/lampp y tus páginas o scripts php, deberán ir en el directorio /opt/lampp/htdocs, además que root es propietario de este directorio. Si necesitas
VirtualHost, he aquí el propósito de este sencillo tutorial.

copia escribió:

vaya no se puede editar el tema, solo queria anotar que trabajo con xampp y codeigniter como framework.

Al framework, le agrege doctrine como plugin y funciona perfectamente con mysql pero no con postgres.

Acabo de hacer una prueba con otra aplicacion que no tiene doctrine y si me reconoce a postgres por lo que creo que me conecto bien.

Ahora solo quedaria dos preguntas. los errores de deprecated se corrigen?? o existe algun addon mas nuevo para xampp??

Si ha actualizado a PHP 5.3, hay muchas posibilidades de que vas a correr en algunas advertencias o mensajes en desuso función.

Un ejemplo es el ereg familia de funciones, que se ha ido para siempre, ya que eran más lentos y se sintió menos familiar que la alternativa compatible con Perl

EDITO:
No es precisamente un addons, pero si una actualización para el PHP 5.3 que te puede ayudar en lo que quieres.

Aqui

Gracias, por responder.

El link que me dio no lleva a ningun lado, y bueno no entendi mucho lo que dijo.

copia escribió:

Gracias, por responder.

El link que me dio no lleva a ningun lado, y bueno no entendi mucho lo que dijo.

Deberías compilar el Kernel primero, es la ayuda parcial... creo que esto te ayudará mejor... pincha aquí
"No entiendo lo que no has entendido..."